Commit 60e11820 authored by Jérémy Destin's avatar Jérémy Destin
Browse files

Merge branch 'chore/npm_deps_update' into 'master'

Update NPM dependencies (resolve npm audit warnings, update angular)

See merge request urgi-is/gpds!11
parents 30fd00c8 318c8564
......@@ -42,7 +42,8 @@
"node_modules/leaflet.markercluster/dist/MarkerCluster.Default.css"
],
"scripts": [],
"baseHref": "/gpds-dev/"
"baseHref": "/gpds-dev/",
"es5BrowserSupport": true
},
"configurations": {
"production": {
......
This diff is collapsed.
......@@ -12,15 +12,15 @@
},
"private": true,
"dependencies": {
"@angular/animations": "7.0.4",
"@angular/common": "7.0.4",
"@angular/compiler": "7.0.4",
"@angular/core": "7.0.4",
"@angular/forms": "7.0.4",
"@angular/http": "7.0.4",
"@angular/platform-browser": "7.0.4",
"@angular/platform-browser-dynamic": "7.0.4",
"@angular/router": "7.0.4",
"@angular/animations": "7.2.7",
"@angular/common": "7.2.7",
"@angular/compiler": "7.2.7",
"@angular/core": "7.2.7",
"@angular/forms": "7.2.7",
"@angular/http": "7.2.7",
"@angular/platform-browser": "7.2.7",
"@angular/platform-browser-dynamic": "7.2.7",
"@angular/router": "7.2.7",
"@types/leaflet": "1.2.14",
"@types/leaflet.markercluster": "1.0.3",
"@ng-bootstrap/ng-bootstrap": "4.0.0",
......@@ -32,24 +32,26 @@
"leaflet.markercluster": "1.4.1",
"ngx-moment": "3.3.0",
"popper.js": "1.14.6",
"rxjs": "6.3.3",
"rxjs": "6.4.0",
"trait-ontology-widget": "git+https://github.com/gnpis/trait-ontology-widget.git#v2.2.1",
"zone.js": "0.8.26"
"tslib": "1.9.3",
"zone.js": "0.8.29"
},
"devDependencies": {
"@angular-devkit/build-angular": "0.12.2",
"@angular/cli": "7.0.6",
"@angular/compiler-cli": "7.0.4",
"@angular/language-service": "7.0.4",
"@angular-devkit/build-angular": "0.13.2",
"@angular/cli": "7.3.4",
"@angular/compiler-cli": "7.2.7",
"@angular/language-service": "7.2.7",
"@types/jasmine": "2.8.12",
"@types/jasminewd2": "2.0.6",
"@types/node": "8.9.5",
"ajv": "6.9.1",
"codelyzer": "4.5.0",
"jasmine-core": "3.3.0",
"jasmine-spec-reporter": "4.2.1",
"karma": "3.1.1",
"karma": "4.0.1",
"karma-chrome-launcher": "2.2.0",
"karma-coverage-istanbul-reporter": "2.0.4",
"karma-coverage-istanbul-reporter": "2.0.5",
"karma-firefox-launcher": "1.1.0",
"karma-jasmine": "1.1.2",
"karma-jasmine-html-reporter": "1.4.0",
......@@ -59,6 +61,6 @@
"ts-node": "7.0.1",
"tslint": "5.11.0",
"tslint-eslint-rules": "5.4.0",
"typescript": "3.1.6"
"typescript": "3.2.4"
}
}
......@@ -19,7 +19,7 @@ module.exports = function (config) {
},
coverageIstanbulReporter: {
dir: require('path').join(__dirname, '../coverage'),
reports: ['html', 'lcovonly'],
reports: ['html', 'lcovonly', 'text-summary'],
fixWebpackSourcePaths: true
},
reporters: ['progress', 'kjhtml', 'junit'],
......@@ -44,6 +44,7 @@ module.exports = function (config) {
flags: ['--no-sandbox'] // required for Gitlab CI
}
},
singleRun: false
singleRun: false,
restartOnFileChange: true
});
};
......@@ -18,62 +18,51 @@
* BROWSER POLYFILLS
*/
/** IE9, IE10 and IE11 requires all of the following polyfills. **/
import 'core-js/es6/symbol';
import 'core-js/es6/object';
import 'core-js/es6/function';
import 'core-js/es6/parse-int';
import 'core-js/es6/parse-float';
import 'core-js/es6/number';
import 'core-js/es6/math';
import 'core-js/es6/string';
import 'core-js/es6/date';
import 'core-js/es6/array';
import 'core-js/es6/regexp';
import 'core-js/es6/map';
import 'core-js/es6/weak-map';
import 'core-js/es6/set';
/** IE9, IE10, IE11, and Chrome <55 polyfills are now automatically handled with the
* `"es5BrowserSupport": true` property in `angular.json`
* See https://blog.ninja-squad.com/2019/01/31/angular-cli-7.3/
*/
/***************************************************************************************************
* Zone JS is required by default for Angular itself.
*/
import 'zone.js/dist/zone'; // Included with Angular CLI.
/**
* If the application will be indexed by Google Search, the following is required.
* Googlebot uses a renderer based on Chrome 41.
* https://developers.google.com/search/docs/guides/rendering
**/
// import 'core-js/es6/array';
/** IE10 and IE11 requires the following for NgClass support on SVG elements */
// import 'classlist.js'; // Run `npm install --save classlist.js`.
/** IE10 and IE11 requires the following for the Reflect API. */
// import 'core-js/es6/reflect';
/**
* Web Animations `@angular/platform-browser/animations`
* Only required if AnimationBuilder is used within the application and using IE/Edge or Safari.
* Standard animation support in Angular DOES NOT require any polyfills (as of Angular 6.0).
**/
*/
// import 'web-animations-js'; // Run `npm install --save web-animations-js`.
/**
* By default, zone.js will patch all possible macroTask and DomEvents
* user can disable parts of macroTask/DomEvents patch by setting following flags
* because those flags need to be set before `zone.js` being loaded, and webpack
* will put import in the top of bundle, so user need to create a separate file
* in this directory (for example: zone-flags.ts), and put the following flags
* into that file, and then add the following code before importing zone.js.
* import './zone-flags.ts';
*
* The flags allowed in zone-flags.ts are listed here.
*
* The following flags will work for all browsers.
*
* (window as any).__Zone_disable_requestAnimationFrame = true; // disable patch requestAnimationFrame
* (window as any).__Zone_disable_on_property = true; // disable patch onProperty such as onclick
* (window as any).__zone_symbol__BLACK_LISTED_EVENTS = ['scroll', 'mousemove']; // disable patch specified eventNames
*
* in IE/Edge developer tools, the addEventListener will also be wrapped by zone.js
* with the following flag, it will bypass `zone.js` patch for IE/Edge
*
* (window as any).__Zone_enable_cross_context_check = true;
*
*/
// (window as any).__Zone_disable_requestAnimationFrame = true; // disable patch requestAnimationFrame
// (window as any).__Zone_disable_on_property = true; // disable patch onProperty such as onclick
// (window as any).__zone_symbol__BLACK_LISTED_EVENTS = ['scroll', 'mousemove']; // disable patch specified eventNames
/*
* in IE/Edge developer tools, the addEventListener will also be wrapped by zone.js
* with the following flag, it will bypass `zone.js` patch for IE/Edge
*/
// (window as any).__Zone_enable_cross_context_check = true;
/***************************************************************************************************
* APPLICATION IMPORTS
*/
......@@ -2,6 +2,7 @@
"compileOnSave": false,
"compilerOptions": {
"baseUrl": "./",
"importHelpers": true,
"outDir": "./dist/out-tsc",
"sourceMap": true,
"declaration": false,
......
{
"rulesDirectory": [
"node_modules/codelyzer",
"codelyzer",
"node_modules/tslint-eslint-rules/dist/rules"
],
"rules": {
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment