Commit 5909ffd4 authored by Langella Olivier's avatar Langella Olivier
Browse files

transitional packages added

parent 54796068
libpappsomspp (0.5.1-1) stretch; urgency=medium
* better packaging
* mutation support
-- Olivier Langella <olivier.langella@u-psud.fr> Sat, 23 Mar 2019 07:27:31 +0100
libpappsomspp (0.5.0-1) stretch; urgency=medium
* library entirely refactored with Filippo Rusconi
......
......@@ -18,10 +18,20 @@ Vcs-Browser: https://sourcesup.renater.fr/scm/browser.php?group_id=1721
Vcs-Git: git://git.renater.fr/pappsomspp.git
Package: libpappsomspp-qt5-0
Depends: libpappsomspp0, ${misc:Depends}
Architecture: all
Priority: optional
Section: oldlibs
Description: transitional package
This is a transitional package. It can safely be removed.
Package: libpappsomspp0
Section: libs
Architecture: any
Multi-Arch: same
Replaces: libpappsomspp-qt5-0 (<< 0.5.1)
Breaks: libpappsomspp-qt5-0 (<< 0.5.1)
Depends: ${shlibs:Depends},
${misc:Depends},
Description: C++ library to handle proteomic data (non-gui runtime files)
......@@ -31,10 +41,20 @@ Description: C++ library to handle proteomic data (non-gui runtime files)
This package ships the non-GUI library.
Package: libpappsomspp-qt5-dev
Depends: libpappsomspp-dev, ${misc:Depends}
Architecture: all
Priority: optional
Section: oldlibs
Description: transitional package
This is a transitional package. It can safely be removed.
Package: libpappsomspp-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Replaces: libpappsomspp-qt5-dev (<< 0.5.1)
Breaks: libpappsomspp-qt5-dev (<< 0.5.1)
Depends: libpappsomspp0 (= ${binary:Version}),
${shlibs:Depends},
${misc:Depends},
......@@ -45,10 +65,20 @@ Description: C++ library to handle proteomic data (development files)
This package ships the development files.
Package: libpappsomspp-widget-qt5-0
Depends: libpappsomspp-widget0, ${misc:Depends}
Architecture: all
Priority: optional
Section: oldlibs
Description: transitional package
This is a transitional package. It can safely be removed.
Package: libpappsomspp-widget0
Section: libs
Architecture: any
Multi-Arch: same
Replaces: libpappsomspp-widget-qt5-0 (<< 0.5.1)
Breaks: libpappsomspp-widget-qt5-0 (<< 0.5.1)
Depends: ${shlibs:Depends},
${misc:Depends},
Description: C++ library to handle proteomic data (gui runtime files)
......@@ -58,10 +88,20 @@ Description: C++ library to handle proteomic data (gui runtime files)
This package ships the GUI library.
Package: libpappsomspp-widget-qt5-dev
Depends: libpappsomspp-widget-dev, ${misc:Depends}
Architecture: all
Priority: optional
Section: oldlibs
Description: transitional package
This is a transitional package. It can safely be removed.
Package: libpappsomspp-widget-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Replaces: libpappsomspp-widget-qt5-dev (<< 0.5.1)
Breaks: libpappsomspp-widget-qt5-dev (<< 0.5.1)
Depends: libpappsomspp-widget0 (= ${binary:Version}),
${shlibs:Depends},
${misc:Depends},
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment