Commit 62d82b0d authored by Gauthier Quesnel's avatar Gauthier Quesnel
Browse files

README: add MacOS and Windows support

parent 2113b7d2
...@@ -11,24 +11,40 @@ v0.1.0, 2020-xx-xx ...@@ -11,24 +11,40 @@ v0.1.0, 2020-xx-xx
Copyright © 2020 http://www.inrae.fr/en[INRA] Copyright © 2020 http://www.inrae.fr/en[INRA]
The software is released under the https://www.boost.org/LICENSE_1_0.txt[Boost The software is released under the https://www.boost.org/LICENSE_1_0.txt[Boost license]. See the LICENSE file.
license]. See the LICENSE file.
== Requirements and recommended == Requirements and recommended
Irritator works for Linux, Windows and MacOS.
* `cmake` (≥ 3.11) * `cmake` (≥ 3.11)
* $$C++$$ compiler with $$C++20$$ support: * $$C++$$ compiler with $$C++20$$ support:
** `gcc` ≥ 8 (https://www.gnu.org/software/gcc/projects/cxx-status.html[notes]) ** `gcc` ≥ 8 (https://www.gnu.org/software/gcc/projects/cxx-status.html[notes])
** `clang` ≥ 9 (https://clang.llvm.org/cxx_status.html[notes]) ** `clang` ≥ 9 (https://clang.llvm.org/cxx_status.html[notes])
** `visual studio 2019 16.0` (https://docs.microsoft.com/en-us/visualstudio/releasenotes/vs2017-relnotes[notes]) ** `visual studio 2019 16.0` (https://docs.microsoft.com/en-us/visualstudio/releasenotes/vs2017-relnotes[notes])
** `Xcode 12` (https://apps.apple.com/app/xcode[notes])
=== Linux
For recent Debian GNU/Linux and Ubuntu derivatives. Install the glfw3 and OpenGL libraries. On Debian GNU/Linux and Ubuntu derivatives.
[source,bash] [source,bash]
.... ....
apt-get install build-essential cmake libglew2 libglew-dev libglfw3-dev libglx0 libopengl0 libgl1-mesa-dev apt-get install build-essential cmake libglew2 libglew-dev libglfw3-dev libglx0 libopengl0 libgl1-mesa-dev
.... ....
=== Windows
Install (https://visualstudio.microsoft.com/[Visual Studio 2019]) with `cmake`
support then open the Irrirator source directory and build.
=== MacOS
Install (https://apps.apple.com/app/xcode[Xcode 12]) and Xcode Command Line
Tools via the command `xcode-select --install` in terminal. Then using
(https://brew.sh[Homebrew]), install `cmake`, `glew` and `glfw` the OpenGL
dependencies.
== First installation == First installation
First, we clone Irritator git repository and the submodule: First, we clone Irritator git repository and the submodule:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment